2016 Interactive Fiction Competition


#102

Cool. One of my objectives in this discussion is to encourage more participation by more participants. As I’ve said several times, “the more the merrier.”


#103

I donated my prize after the comp opened (because I forgot to do it beforehand). I’m pretty sure you can donate prizes up until votes are tallied.


#104

Well, I’m trying to encourage certain types of works, so the right time would’ve been several months ago.


#105

I finished “You are standing in a cave…”, after one fairly small hint. Where are you stuck?


#106

I suspect next year’s authors would be more likely to notice a special prize in this year’s pool, added now, than in next year’s pool, added months ahead of time. On the other hand, I suppose it does seem poor form to add a special prize once you’ve seen this year’s entries (e.g. Best Game About Toilets).


#107

Well, there are no games of the type I’m looking for in the comp this year (I think), so it might go unnoticed.

On the other hand, it’d cost me nothing…


#108

I’m very interested in knowing more. I found numerous fairly serious bugs in the game. Skimming my transcript, examples are:

In the starting room, we’re told there are three exits: N, NE, SW. Yet if you attempt to go W, you get transported to a secret room, where you suddenly have a torch that you never constructed before.

I was told my knife (which only had one good blade) broke, and some turns later when I tried to use the chisel I was told I again used the knife (which by now had both blades broken).

Anyway, rather than go on about that, if you say it can be finished I’d like to do so, as well as correct my previous statement that it’s unresolvable. Basically, when I quit in frustration, I

was at the Dark Room across the ice bridge. I need to construct a torch. I tried so many variations on putting the moss on the wood/securing the moss to the wood and lighting the moss or lighting anything (I can’t even light a match, response “What purpose would it serve to burn that?”).

So, I need light to fiddle around with the door in the dark room.

Based on what I read in the thread I linked earlier, there seems to be no way to do any of these things in the current Inform version of the game.

How did you overcome these issues?


#109

That’s where I was stuck too. There’s a non-standard verb you’ll need to guess. (I was told the verb, but I think it’s guessable if you know it exists.)


#110

I tried so many verbs, I gave up in futility.

If you know the term off-hand, when you’re making a post you can click the flower/gear (probably a gear rather than a flower) next to the smiley face in the composition area to get the option to blur out spoilers if you prefer.

Thanks.


#111

The magic verb is COMBINE.


#112

Thanks, dougo. I can’t believe I didn’t try that… if you saw my transcript, the number of terms I tried was astonishing.

Anyway, I only played this entry for about an hour, so I have plenty of time left to check out the rest. I’m still concerned about bugs I found, but at least I’ll be able to see the whole entry’s content now and revise my score accordingly.


#113

Apparently spoiler tags are not hidden in RSS. That’s disappointing. (They are hidden in email, at least.)


#114

If we both had trouble with the mechanic, perhaps getting the info out there will be for the best.

I’m looking at “You Are Standing in a Cave” right now. The subsequent action to get the thing we were talking about to do its job took some verb guessing as well.

The game has many of these issues, as well as so many unimplemented scenery descriptions. If the author is new to Inform that’s excusable, but it seems a shame to have so many user-friendliness issues when the general design for the game was so detailed and thorough.

Okay, I found two different ways to successfully end the game. Overall all, then, it’s decent entry (not great, not horrible). The endings were very abrupt-- I would have preferred to find out some more info about my character and their circumstances, but we can’t have everything we want.


#115

Filed https://github.com/discourse/discourse-spoiler-alert/issues/23.


#116

Say, vaporware, if you’re here anyway…

How can one embed a youtube video in a post here? I tried earlier, and couldn’t figure it out.


#117

Just paste the URL.


#118

Thanks. I was trying the “embedded url” from youtube earlier, I think.


#119

I have a bookmark folder, I right-click on it and choose to “open all in tabs”. :slight_smile: I do the same with a Webcomics folder. It’s just routine.

If you wish, I’m open to discussing the things you disagree with privately. I expect that, now that the issue seems over, I’ll be able to adopt a less brusque tone.


Re Detectiveland, I haven’t played it yet of course, but funnily enough I DID play Draculaland a few days ago.

I just can’t get into a parser game with no parser. I get distracted, somehow. I never feel like I’m communicating with the game. It’s “Colder Light” all over again. It’s a worthy attempt, to try and bring a point and click interface to a parser game, and Robin Johnson is an author I greatly respect. But… I don’t know, it never works for me.

EDIT - Interestingly, the one parser/CYOA hybrid I can remember really working for me was Hallowmoor. And there’s a big difference there. Draculaland, Detectiveland (I gather) and Colder Light were all primarily parser games doing away with the parser. Hallowmoor was a Twine game that did not try to replace the parser; instead, it used the tools it had available and built up from there.

This may be more significant than it seems. Robin’s and Ingold’s attempts created a parser game without a parser - a mutilated thing. The twine version of COloratura feels similarly mutilated to me. Merk created a twine game with more involved mechanics than usual CYOA - an evolved, mutated thing.

I’ve seen very few people share this opinion, so I guess it’s mostly me. Still, I do think Merk had the right idea. We don’t want to constrain the parser, I don’t think; we don’t want to make things look like a parser game where you have limited and set options. We may instead want to expand on the parser-less game. A mutilated parser game looks reductive, and unappealing (visually, Draculaland was very unappealing. with options to click all over the screen). An expanded CYOA/Twine game, with the options appearing as naturally as they do in all Twine games, plays to the strength of Twine.

I’m really hoping severedhand’s CYOA extension gets released and gets some use. That may lead to much better “parserless parser games”, without the cumbersome task of having to reinvent the interface.

EDIT 2 - On that note, I do believe a true parser/CYOA hybrid
is the future of IF. Parser games with CYOA segments where the parser would not be up to the task, and vice versa.

Hey, you guys, any games you’ve played on this 2016 comp do this? I might be tempted to check them out before the comp is over!

EDIT 2.5 - Note to self: check out “Texture” games as potential good hybrids.


#120

I have to say I quite enjoyed the interface Robin created for his clickable parser games. I too discovered Draculaland a few weeks ago. Initially I cringed at the sight of what looked like plain Scott Adams for mobile phones, but I can’t argue with the humor and the workable interface (it works best in landscape mode, with 2 panes).

I had a fun time with it. It’s all parserland: navigating, inventory-based, puzzlefeast gameplay. Except no guess-the-verb whatsoever: everything is listed together with verbs to tap/click. Those lists may change depending on context, like a water source nearby to fill your glass. So I guess guess-the-verb is traded for go-through-inventory-seeking-verbs. But it’s really much more agile gameplay for mobile than typing things, because while it’s ok to type typos to friends in whatsapp, it’s not for IF.

Unfortunately, screen space is so constrained because of panels for inventory and verbs that it really only works for minimalist text-adventures in Scott Adams tradition.

that said, I’m likely to rate Detectiveland quite high. but first, I’ll have a look at Deja Vu :wink:


#121

There are some other entries that play with the parser format in other ways, such as Queen’s Menagerie, but I don’t think that particular approach is likely to catch on as it was both cumbersome and slightly confusing. If one wanted to do such a thing, the approach taken in Detectiveland is a much better technique both for author and for player.

I agree very much. Increasing the player’s engagement is the key. If the particular themes or narrative style of a work suggest this is best done is a parser only format, use a parser only. If (to use a horribly vague phrase) the story is best told in format that combines point-click, graphical elements, and text, then one should take that approach instead. The important think is the experience provided to the end-user, not some philosophical committment to X method of communication between author and player.

There are clear pitfalls in an approach that merges text-only and graphical interfaces. The method used in 1990s Ultima games Savage Empire and Martian Dreams was in my opinion a complete failure, as I consider those games inherently unplayable and frustrating due to interface/interactive technique issues.

There is definitely a problem with screen space in an entry as complex as Detectiveland. Near the end, finding the button for any inventory item can become time consuming. I noticed what seemed to me a bug, that the location/address area fills and then never updates, but the same problem would have otherwise afflicted that area as well.

Though perhaps unnecessary, I’ll clarify that I was earlier only saying the interfaces are similar in Deja Vu and Detectiveland. The content in each is unique and different, though both are detective stories set in the 1930s/40s. Deja Vu was part of a series of games using a similar interface style, including an adaptation of Shadowgate as well as another supernatural mystery called Uninvited. They were all pretty good games.